| | at : |


Archive

Debian Wheezy 에서 Ruby Version Upgrade(1.9 > 2.1) #Metasploit 업그레이드, rvm,rbenv 하훌 rwxr-xr-x 0 2/20/2015



Debian Wheezy 에서 Ruby Version Upgrade(1.9 > 2.1) #Metasploit 업그레이드, rvm,rbenv

Permission rw-r--r--
Author 하훌
Date and Time 2/20/2015
Label
License 크리에이티브 커먼즈 라이선스



오랜만에 노트북에서 Metasploit 업데이트를 하였더니 패키지 하나가 의존성 문제가 걸리더군요..

gem 으로 설치하려 했으나, 발생하는 건 ruby2.1 이상에서 설치 가능하다는 메시지였습니다.

rvm이나 rbenv를 통해 간단하게 업그레이드가 가능합니다.
(Upgrade Ruby version :: 1.9 -> 2.1)

rvm install 2.1.5 &&
rvm --create --versions-conf use 2.1.5@metasploit-framework &&
pushd ..; popd &&
bundle install

source /etc/profile


혹시나 rvm 설치가 안된다면 아래와 방법으로 설치 가능합니다.
(Install RVM)
# 키 세팅
gpg --keyserver hkp://keys.gnupg.net --recv-keys 409B6B1796C275462A1703113804BB82D39DC0E3

#curl로 rvm 다운로드 및 실행
\curl -sSL https://get.rvm.io | bash


#/etc/profile 적용 후 사용
source /etc/profile




#--------------------------------------------------#
.bashrc

...
source /etc/profile










Share







HAHWUL
HACKING | PENETRATION-TEST | CODING
HACKERONE : GIT : 0DAY-TODAY : EXPLOIT-DB : PACKETSTORM
GOOGLE+ | HAHWUL@GMAIL.COM | TWITTER
WWW.HAHWUL.COM






Recent Post

0 개의 댓글:

댓글 쓰기